Video missing in Podcast App

DaveWT

Well-Known Member
Last night I started to watch the MacBreak Weekly Video podcast in the Podcast app on my iMac with Catalina 10.15.1
All was well and the video displayed normally but it was late and I decided to pause the podcast until morning. This morning I have resumed and while the audio content is there, I can see no way to get the video playing again. I tried restarting the iMac and then resuming the podcast but still no video. Hopefully this isn't a "feature" of the Podcast app on the Mac. (Prior to Catalina I watched / listened to my podcasts in iTunes.)

Dave Teece
 

chas_m

Well-Known Member
Not sure what happened there but try deleting the episode and re-downloading it.
 

DaveWT

Well-Known Member
Thanks for that suggestion, Chas. I was about to try that today, but oddly enough anytime I tried to just resume the podcast yesterday, I only had audio and no video but this morning as soon as I hit "resume playing" it gave me the whole experience - audio and video. I will experiment again when I get a chance on another video podcast.
 

DaveWT

Well-Known Member
Just to report the identical thing happened to me again today. I paused the MacBreak Weekly podcast and when I had time to come back to it and "resume playing" all I got was the audio. I have quit the Podcast application and back in with no change. And I logged into another user account, then back into my own account with no change. If it doesn't give me the video portion back tomorrow when I try it again, I will try the delete and re-download.

Dave
 

DaveWT

Well-Known Member
I did after the first incident and then thought maybe I was hasty. But after the second incident I am glad I did.
 

DaveWT

Well-Known Member
This happened to me again tonight. This time I quit the Podcast app and relaunched with no change. Then restarted the iMac, launched the Podcast app and resumed playing the podcast, still with no video. So then I came to this forum to ask for a solution and found my old thread where I had already asked. (Ah, the memory of a senior citizen!). So following the suggestion from Chas, I wanted to "delete the episode". I couldn't really figure out how to do that in the Podcast app but dragged the progress bar to the end and let it think I was done. Then after some poking around I got it to restart. Yippee, this time it came up with video too so I just had to drag the progress bar to where I had left off. Thanks Chas.
 
Top