Can't get movie from iTunes to Apple TV

DaveWT

Well-Known Member
My system:
Mid 2011 iMac with Sierra (10.12.1)
4th generation Apple TV with tvOS 10.0 (now tried with 10.0.1)

I do not rent a lot of movies but have rented a few in previous versions of the operating system - probably Yosemite and maybe in El Capitan. This was probably my first movie rental with Sierra.

The way I remember doing it in the past, was to rent a movie via iTunes on my iMac. Shortly after I completed the rental steps a dialog box would pop down saying the movie was ready to play and prompting me to “play now” or “play later”. I would choose the latter and then at some later time we would sit down to our TV and play the movie through our Apple TV via Home Sharing from the iMac.

The only hiccup I recall is that after an OS update (e.g.. Yosemite to El Capitan) the Apple TV would not display anything on my iMac and I had to go into iTunes on my iMac, stop Home Sharing and then restart it again.

For a movie I rented on Oct. 25 in iTunes on my iMac, after I had completed the steps to rent it, I did not see the usual dialog box saying it was “ready to play”. But I assumed it was already on my iMac.

Later, that day, I attempted to watch the movie through my Apple TV. This time, I stopped and restarted Home Sharing in iTunes on my iMac but my computer still did not show up on the Apple TV. Then I stopped and restarted Home Sharing on the Apple TV itself, something I have never had to do before. At this point my iMac showed up but there were no rental movies showing.

I assumed that the earlier rental hadn’t worked so I returned to my iMac and tried to rent the movie again. This time it told me that I had already rented it, and I was to go to Account > Check For Available Downloads but when I went there it showed nothing.

So then I went back to the Apple TV and rented the movie there (which I probably should have done from the beginning) and we watched it the same evening there. (And I was billed twice, for the iMac version and again for the Apple TV version, but that is not my concern here.)

I have since looked at my iMac’s iTunes under Movies > Rented and see this movie showing there and saying it “Expires in 29 days” so am not sure why it wouldn’t have shown up via my Apple TV on Oct. 25

I was thinking that I may have signed out of the iTunes store on my iMac before the evening attempt to watch it via the Apple TV and that may have been the reason it did not show up there at that time. However, I tried it again this morning while I was definitely signed into iTunes on the iMac and the movie still could not be found via the Apple TV.

The other curiosity is why when I rented it on the iMac it didn’t give me an indication that it was “ready to play” as I believe such movie rentals used to do.

I just want to make sure I know how to properly do this on a future occasion when I might want to rent another movie. In some cases I will want to watch the movie on my iMac and sometimes via the Apple TV and that is why in the past I have done the rental on the iMac.

Any thoughts, missed steps or do I just remember past successes incorrectly?
 

tfindlay

Administrator
Staff member
I don't know what might have gone wrong with your order through iTunes but I'm pretty sure you can get a refund if you contact Apple.

I recommend ordering movies directly from your Apple TV. It has been very reliable for me.

Terry
 

DaveWT

Well-Known Member
Yes, I did contact Apple and they did refund the cost of one of the rentals. But I didn't really care about that. I really wanted a chance to question what went wrong with my method but their automatic response didn't allow me that opportunity.

As to renting on the Apple TV, I am not always sure whether I will choose to watch the movie on my iMac or later on my TV, so I have always rented on the iMac and then Home Shared it to the Apple TV if I later decide to watch it on the TV.

I haven't investigated whether a movie rented on the Apple TV could be Home Shared to the iMac.
 

chas_m

Well-Known Member
I believe you mentioned that you restarted Home Sharing on your iMac, and that was a good step to try. I believe since you upgraded the operating system however, another thing to try would have been to restart the Mac entirely, check to make sure you are signed into the iTunes store (I assume you only have one account), make sure Home Sharing is on, and then "re-add" this "new" iMac to your Apple TV. That might have solved the issue, and perhaps it will in the future. You should not have to do this more than once, but I'm guessing Apple made some changes to AirPlay that may or may not be affecting your setup. This sort of issue could also be caused if you have an Apple TV older than the third-generation (small black) model.

One last thing: Apple TV's tvOS has also been updated a few times recently, perhaps make sure that you're up-to-date on that as well. Can't hurt, might help. :)
 

DaveWT

Well-Known Member
Thanks for all your thoughts, Chas, but all you have suggested had been done. Apple TV is 4th generation and with the latest tvOS updates. (I was one version back when I first encountered this problem, but have since updated and tried again with no improvement.

I have powered off the Mac and restarted it, turned off Home Sharing on both the Mac and the Apple TV and restarted it in both places (to the proper account, of course.)

There was another update to iTunes (12.5.3) which I have just applied and I must admit I haven't tried this since then. I will try that next, repeating all the stops and starts of the various components along the way to see if anything has changed.
 

chas_m

Well-Known Member
It wasn't clear from your response if you tried what I suggested, i.e. deleting the iMac as a connected computer from your Apple TV and then re-adding it. Keep us posted.
 

DaveWT

Well-Known Member
Well on the Apple TV I logged out everywhere I could find, but perhaps I need another look at this.

I have also tried under the latest version of iTunes 12.5.3.17 just received yesterday with no help.

I will have another look at whether I missed some other way of logging out my iMac and coming back in and let you know if it helps.
 

DaveWT

Well-Known Member
OK, Chas, maybe (likely) I am just been thick. How do I "delete my iMac as a connected computer from my Apple TV"?

I had another look just now and can't find anything in settings on the Apple TV that specifically mentions my iMac.

I have signed out of iCloud and back in, signed out of the iTunes store and back in, and turned off Home Sharing and turned it back on, all on the Apple TV. On the iMac I have restarted the iMac, turned off Home Sharing and back on. I also checked that I was signed into the iTune store in iTunes. While there I noticed under the Account menu heading, "Authorizations > Authorize this computer". Is this something that could have been turned off as far as the Apple TV is concerned? I am not clear on just what I would be authorizing this computer to do at this point. All my other iTunes functions are working correctly on my iMac and my iPhone (e.g.. music, photos etc.)

Is it just my memory failing on how I think this used to work? I am sure in the past if I rented a movie on the iMac, all I needed was Home Sharing to be on at both ends and then when I went to the Apple TV and looked at my computer there, I would see a heading called "Rentals" where I would find the movie I had previously rented on the iMac. Then I could just start playing it on the Apple TV.

I guess an alternate way would be to start playing the movie on the iMac and use Airplay to see it on the Apple TV? But I don't remember doing that in the past, and not sure at what point I would have to enable Airplay on the iMac to send it over.
 

DaveWT

Well-Known Member
More weirdness... In trying to play this recently rented movie when I went to my Apple TV there was never a "Rentals" section appearing in my Library. I began to suspect there may have been some problem with the rented movie even though it appears in my iTunes under "Rentals" as I had encountered a "different" experience when trying to rent it from the iTunes Store.

Today I rented another movie (on my iMac, as before.) Unlike the previous rental, this one showed up in my iTunes "Rentals" area immediately alongside the previous one, so I had great expectations that it would now play via my Apple TV.

I was really excited then to go to my Apple TV and now find there is a "Rentals" section appearing in my Library, which hadn't happened with the previous rental. But when I click on it, I get the message: "There are no movie rentals in this library."

So strange that renting the movie on the iMac caused this "Rentals" section to appear on the Apple TV via Home Sharing, but no movie then appears.
 

chas_m

Well-Known Member
DaveWT":cr6lkywq said:
I also checked that I was signed into the iTune store in iTunes. While there I noticed under the Account menu heading, "Authorizations > Authorize this computer".
I think this is something to do with the issue. If your computer isn't authorized (to play and share your iTunes content, the the Apple TV can't do anything with that computer.
 

DaveWT

Well-Known Member
The iMac certainly can play music I have in iTunes and videos, photos etc. so I would say it is authorized but maybe I should deauthorize and reauthorize to see what happens.
 
Top